NetVision data center - Possible network performance issues

Incident Report for SPD Hosting

Resolved

This incident has been resolved.
Posted Jan 25, 2026 - 15:59 IST

Investigating

We are aware of a possible issue and are working to determine the scope and impact.
Posted Jan 25, 2026 - 15:48 IST
This incident affected: Cellcom (013).